Skip to main content

Grow Script Not Showing - Code Added To Header In Wordpress

Comments

15 comments

  • Ben Rodriguez

    Hey Benjamin!

    You only need to install Grow's scripts once, so you'll need to choose between the scripts in your header & footer plugin or using the Grow for WordPress plugin on its own.

    Grow cannot verify its scripts on your site because currently it is seeing two end points. Removing either of the ways you have added Grow's scripts to your site, then clearing your cache, should resolve this issue!

    0
  • Benjamin Racey

    Hi!

    I have just removed the script form the header, so that's it's just the grow plugin on my site. 

    My dashboard (under install grow script) is still saying that there is a problem with connectivity. Should it still say this? It does also say that grow is active on my site.

    0
  • Ben Rodriguez

    It can take a little time for Grow to check all the things it needs to ensure connectivity. It looks like right now, Grow Publisher Portal shows that Grow is working and connected and I see Grow on your site!

    If you refresh Grow Publisher Portal, you should not see the connectivity issue message any longer.

    0
  • Tailwagwisdom

    I'm having the same issue. I deleted the script from my headers, cleared the it cache, and then went back to my Grow Publisher Portal and refreshed it about 1 hour later. However, I'm still getting that there's a connectivity issue. Any more thoughts? Or does it take a day or more to connect?

    0
  • AJ

    Hi Ben Rodriguez , I am having the same issue on my website. I removed the script from header text and have only plugin installed. Can you check to see if its working correctly?

    0
  • Iulia Vasile

    I have the same issue. At first I also had both the plugin and the code installed, but now I have uninstalled the plugin, and there's still an issue with connectivity. It's been 1 day, cleared/stopped all caching services I have and still can't see the code but the code is there. 

    0
  • Ben Rodriguez

    Hey Tailwagwisdom and AJ !

    Are you trying to verify your scripts in Grow Publisher Portal or by going through the Grow for WordPress app in your WP Admin settings? Going through the Grow for WordPress app should connect your site to Grow Publisher Portal and resolve this.

     

    0
  • Ben Rodriguez

    Hi Iulia Vasile !

    How are those scripts installed on your site? There are only three officially supported manual installations of Grow scripts on WordPress: Genesis Hooks, Trellis Hooks, or the Header & Footer Plugin. If you're not going with one of these solutions, there may be issues your developer or tech help can assist you with.

    0
  • Tailwagwisdom

    Hi Ben,

    I have the app connected to the portal. Do I not need to worry about “Check Grow Connectivity” under “Install Grow Script” on the portal? When I click that button, it says there's a connectivity issue. Thanks for the help! I really appreciate it! Terri 

    0
  • Iulia Vasile

    I am using another plugin for the header, so that might the issue. I deleted the code from the Header, and try to connect via the Grow plugin now. it seems that the same connectivity issue appears in the grow portal. What I am doing wrong?

    0
  • AJ

    @Ben Rodriguez, I tried removing and connecting the script using the plugin, but it did not work. I waited for two days to give it time to connect, but whenever I went back on the plugin on WP, it was disconnected with my grow account.

    Now, I removed the plugin and am trying to connect using the script, but it's still not working. Can you help troubleshooting the issue?

    0
  • Ben Rodriguez

    Tailwagwisdom It looks like Grow's scripts are being optimized and that could be the issue. Grow's scripts also don't appear to be in the head tags on your site, which could be related to the optimization.

    First, I'd recommend excluding Grow from your optimization plugins. The Conflicts and Compatibilities article can help with this.

    If you don't see Grow on your site after excluding it from your optimization plugins and clearing your site's cache and any caching plugins, a different installation is probably the best option.

    0
  • Ben Rodriguez

    Iulia Vasile AJ It sounds like you all may be experiencing the same issues as Terri. Grow's scripts are likely being optimized by an optimzation plugin or they may not be placed in your head tags.

    If excluding Grow from your optimization plugins doesn't help, your tech help or developers should be able to take a closer look at your implementation and help you get Grow installed correclty on your sites.

    0
  • Tailwagwisdom

    Hi Ben!

    WOW!!! Finally working!!!

    It took me a bit to figure out the optimization issue. But I got it!

    Also, it was my fault as well. I read your reply to Benjamin above and thought that if I was using the Grow plugin then, I wasn't supposed to include the script in the header. Thankfully, that was an easy fix. 

    From above:

    “You only need to install Grow's scripts once, so you'll need to choose between the scripts in your header & footer plugin or using the Grow for WordPress plugin on its own.”

    Thank you so much for the help! I've got my fingers crossed that it will help as well. 

    Terri

     

    0
  • Iulia Vasile

    It finally worked for me. I deleted the code from the header (I am using a different plugin for header and footer codes than the ones recommended) and connected to Grow through the plugin only. Then I deleted, purged, and shut off all caching plugins and services I was using (plugins, on the server from my hosting domain, from my current ads platform… all). I waited for 1.5 days, and it worked. I hope this helps if someone is having the same issues. 

    0

Please sign in to leave a comment.